Subject: Re: hpff-interpret: MODULE, USE only, and !hpf$ template

From: Harvey Richardson <[email-masked]>
Date: Tue, 11 Jun 96 14:18:43 BST

---------------------------------------------------------------------------
[email-masked] is a mailing list for corrections,
clarifications, and interpretations related to High Performance Fortran.
Instructions for adding or deleting yourself from this list appear at the
bottom of this message.
---------------------------------------------------------------------------

> > I would say "no".
> > 
> > In general, if something is not a first-class object, then it cannot be
> > used in an Fortran 90 statement.  (If it were, then the program would
> > violate the "if you ignore the directives then it's legal F90" principle.)
> > 
> >                                                 Chuck
> > 
> 
> Just mention a few of violations of the "if you ignore the directives 
> then it's legal F90" principle:
> 
> 	FORALL, EXTRINSIC, PURE
> 
> If any of these is used, the program is no longer legal fortran 90.
> 
> For the original question, I would say it is legal HPF (since a HPF
> program is not legal F90 anyway in many cases).
> 
> -----
> Dr Junxian Liu			email: [email-masked]
> NA Software Ltd			       [email-masked]

You have a strange definition of "directive".  With F95 coming along
this seems a bit academic anyway.

Maybe the solution is:

HPF$ USE M, only :: T

Harvey
---------------------------------------------------------------------------
To (un)subscribe to this list, send mail to
[email-masked].
Leave the subject line blank, and in the body put the line
(un)subscribe <email-address>
---------------------------------------------------------------------------

---

From: Tomasz Haupt <[email-masked]>
Date: Tue, 11 Jun 1996 09:32:09 -0400

>Harvey

It looks quite weird, but maybe it is a solution.
"T" is an HPF object, and it can appear in the code only in the 
directives anyway. So it is consistent at this respect.

Tom