Subject: Re: hpff-interpret: MODULE, USE only, and !hpf$ template

From: [email-masked] (Chuck Koelbel)
Date: Mon, 10 Jun 1996 14:00:53 -0600

---------------------------------------------------------------------------
[email-masked] is a mailing list for corrections,
clarifications, and interpretations related to High Performance Fortran.
Instructions for adding or deleting yourself from this list appear at the
bottom of this message.
---------------------------------------------------------------------------

At 11:03 06/10/96, Larry Meadows wrote:
>
>Is this legal:
>
>
>module M
>!hpf$ template T(100,100)
>!hpf$ distribute T(block,block)
>end module
>
>use M, only:: T
>end
>
>
>T is not a first-class object. If M is USEd, then I guess T is available.
>But can T be named in a F90 statement?
>
>lfm

I would say "no".

In general, if something is not a first-class object, then it cannot be
used in an Fortran 90 statement.  (If it were, then the program would
violate the "if you ignore the directives then it's legal F90" principle.)

                                                Chuck

---------------------------------------------------------------------------
To (un)subscribe to this list, send mail to
[email-masked].
Leave the subject line blank, and in the body put the line
(un)subscribe <email-address>
---------------------------------------------------------------------------

---

From: Tomasz Haupt <[email-masked]>
Date: Mon, 10 Jun 1996 15:29:35 -0400

>violate the "if you ignore the directives then it's legal F90" pri

As an HPF user I find it a little confusing. I do use modules similar to
Larry's module M, without "only:: T" however. Chuck's argument is OK.
Nevertheless T can appear only in a !hpf$ directive, i.e., f90 comment line,
do it does no harm. This way you make life of a programmer easier. 

It saves necessity to write yet another perl script to maintain consistency
of my HPF codes.

Tom

---

From: Junxian Liu <[email-masked]>
Date: Tue, 11 Jun 1996 09:10:53 +0100 (BST)

> violate the "if you ignore the directives then it's legal F90" principle.)

Just mention a few of violations of the "if you ignore the directives 
then it's legal F90" principle:

	FORALL, EXTRINSIC, PURE

If any of these is used, the program is no longer legal fortran 90.

For the original question, I would say it is legal HPF (since a HPF
program is not legal F90 anyway in many cases).

-----
Dr Junxian Liu			email: [email-masked]
NA Software Ltd			       [email-masked]
Roscoe House			
62 Roscoe Street		telephone: +44 151 709 4738
Liverpool L1 9DW		fax:       +44 151 709 5645
---------------------------------------------------------------------------
To (un)subscribe to this list, send mail to
[email-masked].
Leave the subject line blank, and in the body put the line
(un)subscribe <email-address>
---------------------------------------------------------------------------