Subject: hpff-interpret: Forwarded mail...

From: "Larry Meadows" <[email-masked]>
Date: Fri, 8 Mar 1996 17:28:42 -0800 (PST)

---------------------------------------------------------------------------
[email-masked] is a mailing list for corrections,
clarifications, and interpretations related to High Performance Fortran.
Instructions for adding or deleting yourself from this list appear at the
bottom of this message.
---------------------------------------------------------------------------

Since we're on the topic of hpf_local:

! The question is, should this global_lbound return 1 or -104?  
     program xc06
      interface
        extrinsic (hpf_local) function vet(array2,results)
        integer vet
        integer, dimension (:,:,:,:,:,:,:)    :: array2
!HPF$ DISTRIBUTE(BLOCK,BLOCK,BLOCK,BLOCK,BLOCK,BLOCK,BLOCK)::array2
	integer,intent(out):: results
        end function
      end interface

      integer, dimension(-104:-100,2,0:1,-1:1,1:3,-1:0,1:2):: a2
      integer results
!HPF$ DISTRIBUTE(BLOCK,BLOCK,BLOCK,BLOCK,BLOCK,BLOCK,BLOCK)::a2
      integer ::a_res
      integer:: num_procs
      a_res=vet(a2,results)
      print *,results
      end
	
      extrinsic (hpf_local) function vet(array2,results)
      use hpf_library
      use hpf_local_library
      integer vet
      integer, dimension (:,:,:,:,:,:,:)    :: array2
      integer,intent(out):: results
      results=global_lbound(array2, 1)
      return
      end

---------------------------------------------------------------------------
To (un)subscribe to this list, send mail to
[email-masked].
Leave the subject line blank, and in the body put the line
(un)subscribe <email-address>
---------------------------------------------------------------------------

---

From: <[email-masked]> (Henry Zongaro)
Date: Mon, 11 Mar 1996 13:02:24 -0500 (EST)

Hi Larry,

>       results=global_lbound(array2, 1)

     The value returned should be -104.  This is consistent with the examples
shown under GLOBAL_LBOUND and GLOBAL_UBOUND.

Thanks,

Henry