Subject: hpff-doc: parallel-ext.tex

From: Piyush Mehrotra <[email-masked]>
Date: Wed, 16 Oct 1996 11:46:19 -0400 (EDT)

---------------------------------------------------------------------------
[email-masked] is a mailing list for HPF 2.0 language specification
authors and editors.  Instructions for adding or deleting yourself from this
list appear at the bottom of this message.
---------------------------------------------------------------------------

Some proposed changes to Section 8 on parallel extensions.

	- Piyush

Page 166 Line 26
Replace:
    \item The {\tt TASK_REGION} construct provides a the means to create
with
    \item The {\tt TASK_REGION} construct provides the means to create

Page 167 Line 3:
Replace:
    The program begins execution with all processors active.
with
    AN HPF program begins execution with all processors active.

Page 168 Line 47-48
Replace
    One can also use the \texttt{ACTIVE} option of the extended
    \textit{combined-directive}.
with
    One can also use the \texttt{ACTIVE} option of the extended
    \textit{combined-directive} 
    to declare a processors arrangement to be active.

Page 169 Line 31:
Replace:
        target must be distributed onto active processors.  This may be
        achieved by
with
        target must be distributed onto active processors.  This may be
        achieved by:

Page 169 Line 37:
Replace
     \item  Aligning the local variable to an appropriate section of a
                target distributed to all processors
with
     \item  Aligning the local variable to an appropriate section of a
                target distributed to all processors.

Page 169 Line 43
Replace
    particular, if a program contains no \texttt{ON} directives modify a
with
    particular, if a program contains no \texttt{ON} directives which modify a

Page 170 Line 17:
    but this is not critical since HPF does not support dynamics
with
    but this is not critical since HPF does not support dynamic

Page 170 Line 26:
Replace 
    like global variables and follow the rules from globals.
with
    like global variables and follow the rules for global variables.

Page 170 Line 33-34
    performed on a small (non-universal) active processor set.
Why only small - do you mean smaller (non-universal) active processor set?

Page 170 Line 35
Replace
    For a {\tt REDISTRIBUTE} directive,
    the set of  active processors must include
with
    For a {\tt REDISTRIBUTE} directive,
    the set of  active processors must include:

Page 174 Line 4-5:
    The single-statement {\tt ON} directive (i.e. {\it
    simple-on-directive}) precedes the
    statement for which it sets the active processor set,
    and is said to apply to that
    statement.
with
    The single-statement {\tt ON} directive (i.e. {\it
    simple-on-directive}) is said to apply to the first
    non-comment statement that follows it
    and sets the active processor set for it.

Page 174 Line 12-13:
Replace
    processor executing the computation as follows:
with
    processor(s) executing the computation as follows:

Page 175 Line 12:
Replace
    by having all processors compare their processor id to an id (or list of
    ids) generated from the {\tt HOME} clause.
with
    by having all processors compare their processor {\it id} to an {\it id} 
    (or list of
    {\it ids}) generated from the {\tt HOME} clause.

Page 177 Line 3-6:
Replace
    Therefore, no communication outside of the {\tt ON} processor set is
    required to implement  them.
    Scalar {\tt NEW} variables should be replicated over the {\tt ON}
    processor set,
    or allocated to memory areas shared by the {\tt ON} processor set.
with
    Therefore, no communication outside of the active processor set,
    determined by the {\tt ON} directive, is
    required to implement  them.
    Scalar {\tt NEW} variables should be replicated over the active
    processor set,
    or allocated to memory areas shared by the active processor set.

Page 183 Line 21:
Replace
    warning, following the recommendations in Section~\ref{ch-mapping-subr}.
with
    warning, following the recommendations in Section~\ref{ch-mapping-subr}.)

Page 186 Line 39:
Replace
    Explicit use \texttt{CALL}s in {\tt ON} directives is often
with
    Explicit use of \texttt{CALL}s in {\tt ON} directives is often

Page 196 Line 36-37:
Replace
    corresponding processor subset. Further,
with
    corresponding active processor set. Further,

Page 196 Lines 34-38:
These restrictions are repeated in a more precise manner on the
next page (lines 18-30). Is there any point in giving them here?

Page 197 Line 34:
Replace
    the specified executing processors of an execution task need to
with
    the specified processors of an execution task need to

Page 197 Line 39
??Replace??
    executed as normal data parallel code by all processors.  The access
with
    executed as normal data parallel code by all active processors.  The access

Page 200 Line 33
Replace
    !HPF$       END BEGIN
with
    !HPF$       END ON

Page 200 Line 40
Replace
    !HPF$       END BEGIN
with
    !HPF$       END ON

Page 200 Line 48
Insert pagebreak to force first line of example to go on the next page!

Overall the terminology of section 8.4 on tasking regions is very confusing 
with executing and execution tasks etc. Also it needs to be rewritten in
terms of the active processor sets as defined in section 8.1

---------------------------------------------------------------------------
To (un)subscribe to this list, send mail to [email-masked].
Leave the subject line blank, and in the body put the line
(un)subscribe <email-address>
---------------------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 17 Oct 96 15:42:19 -0400

It appears that the new section on TASK_REGION never propagated to the
release again. Chuck - could you integrate it as soon as possible. I sent
you the updated section a few weeks ago and can send it again if it is lost.

I am sorry I was not able to check this sooner which resulted in several
of you reading and commenting on out of date text. Some of the 
corrections/comments received are not relevant anymore, but others are
still valid.

jaspal